Beschriftungen sind textliche und symbolische Anmerkungen, die wichtige Informationen über Netz-Features auf der Webkarte anzeigen. Sie können Ihnen dabei helfen, der Karte klaren, gut lesbaren Text hinzuzufügen, damit Sie Netz-Features identifizieren, die Designabsicht dokumentieren und zusätzlichen Kontext für Planungs- oder Bearbeitungs-Workflows bereitstellen können.
Networks Editor unterstützt drei Arten von Beschriftungen: Freie Beschriftungen, Feature-bezogene Beschriftungen und Block-Beschriftungen.
Freie Beschriftungen und Feature-bezogene Beschriftungen sind Standardkonzepte für Esri-Beschriftungen. Block-Beschriftungen sind ein Networks Editor-Konzept, das mehrere Feature-bezogene Beschriftungen in einem einzigen Beschriftungsblock gruppiert.
Verwenden Sie freie Beschriftungen, um Text hinzuzufügen, der nicht mit einem bestimmten Netz-Feature verbunden ist. In unserem Beispiel fügen wir während der Planung einen Konstruktionshinweis für eine vorgeschlagene Netzerweiterung hinzu.
So erstellen Sie eine freie Beschriftung:
1.Gehen Sie zu Bearbeiten > Beschriftungen.
Die Registerkarte „Beschriftungen“ wird geöffnet.
2.Klicken Sie auf Frei, wählen Sie den Layer und die Beschriftungsklasse aus den jeweiligen Dropdown-Menüs aus und geben Sie dann den auf der Karte anzuzeigenden Text ein.
Um die korrekte Anzeige der Beschriftungen auf der Karte zu gewährleisten, zoomen Sie auf einen geeigneten Maßstab.
Beschriftungen sind nur sichtbar, wenn ihr zugehöriger Layer aktiv und sichtbar ist. Stellen Sie sicher, dass der Layer in der Registerkarte „Layer“ aktiviert ist.
3.Platzieren Sie Ihre neu erstellte Beschriftung mithilfe einer der unten aufgeführten Methoden auf der Karte.
Schaltfläche |
Beschreibung |
|---|---|
|
Platzieren Sie die Beschriftung an einem bestimmten Punkt und drehen Sie sie bei Bedarf, indem Sie die Drehstange ziehen. |
|
Platzieren Sie die Beschriftung zwischen zwei ausgewählten Linien entlang einer gezeichneten Basislinie. |
|
Platzieren Sie die Beschriftung mit einer Führungslinie, indem Sie den Punkt auswählen, auf den die Beschriftung zeigen soll. Klicken Sie dann an der Stelle, an der der Beschriftungstext erscheinen soll. |
4.Klicken Sie auf die Karte, um die Beschriftung an der gewünschten Stelle zu platzieren.
Ihr Konstruktionshinweis ist jetzt erstellt und im Layer „InfoText“ gespeichert.

Sie können dieselbe Beschriftung mehrfach platzieren, indem Sie auf verschiedene Positionen auf der Karte klicken. Um die Beschriftung nur einmal zu platzieren, drücken Sie nach der ersten Platzierung auf Esc.
Feature-bezogene Beschriftungen sind Beschriftungs-Features, die in dynamischer Beziehung zu den Features stehen, die sie beschreiben. Wenn sich die Attribute oder die Geometrie des verknüpften Features ändern, wird die Beschriftung automatisch aktualisiert, um konsistent zu bleiben.
Sie können Feature-bezogene Beschriftungen nur erstellen, wenn diese für das ausgewählte Feature konfiguriert sind. Weitere Informationen hierzu finden Sie in der Esri-Dokumentation.
In diesem Beispiel überprüft ein Versorgungsplaner einen Straßenabschnitt mit mehreren unterirdischen Kabeln. Um eine bestimmte Leitung leichter identifizieren zu können, erstellt er eine Feature-bezogene Beschriftung, die Informationen wie die Kabelspezifikation und das Jahr anzeigt: NAEKBA4x150 / 2010.
So erstellen Sie eine Feature-bezogene Beschriftung:
1.Gehen Sie zu Bearbeiten > Beschriftungen.
Der Bereich „Beschriftungen“ wird geöffnet.
2.Unter Feature-bezogen klicken Sie auf Einzelnes Feature auswählen und dann auf die Stromleitung auf der Karte.
Das Feature wird ausgewählt und die entsprechenden Informationen werden im Bereich angezeigt.
3.Wählen Sie die passende Layer- und Beschriftungsklassenkonfiguration für Ihr Asset aus den jeweiligen Dropdown-Menüs aus; in unserem Beispiel wählen wir Stromleitungsbeschriftung und die Beschriftungsklasse LV Line.
Das Textfeld zeigt die erstellte Beschriftung an.
4.Klicken Sie auf die Karte, um die Beschriftung an der gewünschten Stelle zu platzieren.
Ihre Beschriftung für Kabelspezifikation und Jahr ist jetzt erstellt und in der Webkarte gespeichert.

Sie können die Beschriftung vor dem Platzieren um den gewünschten Winkel drehen, indem Sie die Drehstange ziehen oder den Winkelgrad eingeben.
Wenn Sie ein Feature löschen, wird seine Feature-bezogene Beschriftung automatisch gelöscht.
Wenn das ausgewählte Feature ein Linien-Feature ist, wird die Beschriftung automatisch so gedreht, dass sie vor dem Platzieren mit dessen Drehwinkel übereinstimmt.
Bei Polygon-Features sind die Feature-bezogenen Annotationen parallel zur Polygongrenze ausgerichtet. Bei der Punktauswahl wird der Winkel von der Polygonkante aus gemessen, die der ausgewählten Position am nächsten liegt. Bei der Auswahl einer Polylinie wird der Winkel von der ersten Polygonkante aus gemessen, die von der Auswahllinie gekreuzt wird.
Erstellen Sie mehrere Beschriftungen als einen einzigen Textblock für parallele Linien.
Damit eine Block-Beschriftung erstellt werden kann, muss das ausgewählte Feature für Feature-bezogene Beschriftungen konfiguriert sein.
In diesem Beispiel überprüft ein Versorgungsplaner einen Straßenabschnitt, in dem mehrere unterirdische Versorgungsleitungen nahe beieinander verlaufen. Jede Leitung separat zu kennzeichnen würde das Lesen der Karte erheblich erschweren. Daher skizziert er die nahe beieinander verlaufenden Leitungen, erstellt Block-Beschriftungen und platziert diese dann in einem freien Bereich auf der Karte.
So erstellen Sie eine Block-Beschriftung:
1.Gehen Sie zu Bearbeiten > Beschriftungen.
Der Bereich „Beschriftungen“ wird geöffnet.
2.Unter Feature-bezogen klicken Sie auf Mehrere Features auswählen und zeichnen dann eine Linie, die alle parallelen Linien-Features auf der Karte schneidet.
Die ausgewählten Linien werden auf der Karte hervorgehoben und ihre Informationen werden in dem Bereich angezeigt.
3.Klicken Sie auf den Namen des Asset's, um die ausklappbaren Einstellungen zu öffnen, und wählen Sie dann die Annotationsklasse aus der Dropdown-Liste aus.
Die Dropdown-Liste der Beschriftungsklasse wird gefiltert, sodass nur Klassen angezeigt werden, die für den Subtype des ausgewählten Features gültig sind. Wenn Sie eine Block-Beschriftung erstellen, berücksichtigt Networks Editor die Beziehungsregeln des ausgewählten Features. Wenn genau eine gültige Regel zutrifft, wird die entsprechende Beschriftungsklasse verwendet. Wenn mehrere Regeln gültig sind, wird die erste passende Klasse als Standard ausgewählt. Auf diese Weise lässt sich konfigurieren, welcher Beschriftungs-Subtype als Standard für die einzelnen Layer-Subtypes verwendet wird. Um mehr zu erfahren, rufen Sie die ArcGIS Pro-Dokumentation auf.
Wenn Sie eine Annotationsklasse mit kleinerer Schriftgröße auswählen, wird der Abstand zwischen den Beschriftungen automatisch angepasst.
4.Klicken Sie auf die Karte, um den Beschriftungsblock an der gewünschten Stelle zu platzieren.
Ihre Block-Beschriftung wurde jetzt erstellt und in der Webkarte gespeichert.

In einem Block-Beschriftungstext werden Features geografisch angeordnet, um ihrer visuellen Anordnung auf der Karte zu entsprechen.
Beim Erstellen einer Block-Beschriftung mit Führungslinien platziert das System automatisch Führungslinienanker an den Schnittpunkten, um genau auf die Stellen zu zeigen, an denen die Features die identifizierte Geometrie schneiden.
•Block-Beschriftungen unterstützen nur eine Linie pro Feature-bezogener Beschriftung.
•Die Ausrichtung des Blocks entspricht dem Drehwinkel der Platzierungsposition.
•Die Reihenfolge der Beschriftungen richtet sich nach der Kartenausrichtung.
•Block-Beschriftungen funktionieren mit Linien-, Punkt- und Flächen-Features.
Block-Beschriftungen verwenden den ersten verfügbaren Beschriftungs-Layer und dessen erste Beschriftungsklasse.
Siehe auch Beschriftungen bearbeiten.